Здравейте гостенино! Вход Регистриране


Оценете темата:
  • 0 гласа - средно 0
  • 1
  • 2
  • 3
  • 4
  • 5
Mount на samba сървър
#11
Ок, монтиран е надлежно.
Какво не се получава?

Изпратено от моят HUAWEI GRA-L09 с помощта на Tapatalk
 
Отговор
#12
Проблемът е, че като сложа парола на FTP-то, автоматично слага и на SMB-то. Незнам как да я вкарам и нея в кода. Всичко си работи нормално, но нямам защита. Ако ми видиш IP то и си вътре(не че имам нещо, което крия Smile )Явно ще трябва да опитам по начина от тази тема.

Sent from my OnePlus 2 using Tapatalk
 
Отговор
#13
Няма логика да са с едни пароли, със стоков фърмуер ли е рутъра?
Не знам дали можеш да пуснеш SMB шера без парола, но дори с парола да е, не ти пречи в mount-a да подадеш криденшъли. Също и в LibreELEC става.
Аз пак не разбирам какво те мъчи....
 
Отговор
#14
@Topper
Рутерът ми е все още със стоков фърмуер,но скоро май ще го префлашна с dd-wrt. Много минуси има вече Smile

Днес актуализирах Libreelec до версия 8.2 и сега въобще не мога да монтирам SMB-то. Пробвах и по моя начин, който съм описал в един от постовете ми, пробвах и по този в темата. Принципно самото Libreelec 8.2 си има проблем със Samba, но аз не мога да се справя. Ако някой е монтирал на версия 8.2 да сподели.

Sent from my OnePlus 2 using Tapatalk
 
Отговор
#15
Аз имах проблем с защитени с user и pass smb shares
Май за да го оправя промених нещо в /storege/.smb/smb.conf, но не помня какво точно.
Май бяха редовете:

Код:
client lanman auth = yes
lanman auth = yes

Ето така изглежда в момента моя файл.
Виж какви са разликите с твоя и пробвай. Ще трябва и рестарт след промяна.

Код:
[global]
      preferred master = no
      local master = no
      domain master = no
      client lanman auth = yes
      lanman auth = yes
      socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=65536 SO_SNDBUF=65536
      lock directory = /storage/.smb/
      name resolve order = bcast host

ПП. Шерове без пароли си работеха без проблем
 
Отговор
#16
И при мен нямаше проблем без защита на Libreelec 7.0.3.012j. Днес, както казах минах на 8.2.3.1 и всичко пропадна Smile Ще се мъча и аз, пък да видим какво ще стане.

Sent from my OnePlus 2 using Tapatalk
 
Отговор
#17
Видя ли си конфиг файла?

Само да спомена, че аз не ползвам скрипт за маунтване, а си достъпвам шеровете през файл мениджъра на коди като съм му дал да запомни юзъра и паролата.
 
Отговор
#18
Оправих си проблема с монтирането.Всичко идва от разликата на SMB версията на рутера и LibreELEC! Както @SlaSerX е показал....в неговия .mount файл е показано версия на SMB 2.1.Аз просто го промених на 1.0 и всичко си тръгна.Сега вече имам защитен SMB, монтиран на LibreELEC. Smile
Благодаря за темата отново.

Код:
[Unit]
Description=cifs mount script
Requires=network-online.service
After=network-online.service
Before=kodi.service

[Mount]
What=//192.168.0.1/Home/Recordings/
Where=/storage/recordings
Options=username=user,password=mypassword,rw,vers=1.0
Type=cifs

[Install]
WantedBy=multi-user.target
 
Отговор
#19
А най-чисто е да махнеш дефиницията и те ще се разбират за версията на протокола...мернах го и се сетих за един WinSrv 2016 който ми стопи нервичките, ама се оказа минимална в.2, що ли не ти казах по-рано.

Изпратено от моят HUAWEI GRA-L09 с помощта на Tapatalk
 
Отговор
#20
Не стана при мен с махане на дефиницията! Преди това пробвах и примерния фаил, който е в папката system.d. Там нямаше версия на SMB, но не се получи с него.

Sent from my OnePlus 2 using Tapatalk
 
Отговор
  


Отваряне на: